[Churn IQ 2.0] Service degradation
Incident Report for Cleeng
Resolved
This incident has been resolved.
Posted May 01, 2023 - 10:00 CEST
Update
The problem has been resolved and all services are now back to normal operations.

We will continue monitoring for any potential issues.
Posted May 01, 2023 - 09:59 CEST
Update
We are continuing to investigate this issue.
Posted May 01, 2023 - 09:59 CEST
Investigating
We are encountering a degradation of service with regards to the Churn IQ dashboard. This issue has led to a delay in the display of data pertaining to the reporting metrics. Our team of engineers is actively investigating the matter, and we shall provide regular updates as the situation progresses.
Posted May 01, 2023 - 09:05 CEST
This incident affected: ChurnIQ.