ChurnIQ last 3 days of data missing or incomplete.
Incident Report for Cleeng
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 11:57 CEST
Monitoring
We are already resolving the issue.
Posted Jun 10, 2021 - 09:25 CEST
This incident affected: ChurnIQ 2.0.