ChurnIQ 2.0 Current data not available
Incident Report for Cleeng
Resolved
This incident has been resolved.
Posted Sep 10, 2023 - 22:04 CEST
Identified
We are aware of the fact that the data in ChurnIQ is not up to date and we are currently working to resolve that.

You may expect some data delay due to an external vendor data ingestion delay. Latest data should be available by 10th September 9:55 PM CET.
Posted Sep 08, 2023 - 12:00 CEST
This incident affected: ChurnIQ.