ChurnIQ - Snowflake Outage

Incident Report for Cleeng

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 18:03 CET

Update

Snowflake has provided an updated timeline, with service estimated to be restored by 3:00 PM UTC.

We will continue to monitor and share further updates.
Posted Dec 16, 2025 - 13:44 CET

Identified

We are currently experiencing an external outage with Snowflake.

Due to this, you may experience delayed visibility for the most recent data.

The last successful data refresh occurred at 12:01 AM CET on December 16, 2025.

As of 05:04 UTC, Snowflake has developed a fix and is preparing it for deployment.

Snowflake estimates that the service will be restored within the next 5 hours.
Posted Dec 16, 2025 - 09:49 CET
This incident affected: ChurnIQ.