We are currently experiencing an issue with drill-fields in the ChurnIQ dashboards
Incident Report for Cleeng
Resolved
This incident has been resolved.
Posted Jan 17, 2025 - 10:28 CET
Update
We are continuing to monitor for any further issues.
Posted Dec 18, 2024 - 09:51 CET
Monitoring
Some drill-fields are temporarily unavailable.
We are working to restore the full functionality as soon as possible.
Posted Dec 18, 2024 - 09:29 CET
This incident affected: ChurnIQ.