[Churn IQ 2.0] Service degradation
Incident Report for Cleeng
Resolved
The problem has been resolved and all services are now back to normal operations.

We will continue monitoring for any potential issues.
Posted Apr 06, 2023 - 19:48 CEST
Investigating
We are currently experiencing a service degradation of the Churn IQ dashboard which is causing issues with displaying of the data in the reporting metrics. The problem is currently being investigated by our engineers and we will post continuous updates as the situation develops.
Posted Apr 06, 2023 - 19:26 CEST
This incident affected: ChurnIQ.