Data issues in ChurnIQ
Incident Report for Cleeng
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 16:27 CET
Identified
We have noticed that there are issues with data loading in ChurnIQ we already identified the issue and we are fixing it.

It should take approximately 30 minutes to be resolved.
Posted Nov 08, 2021 - 16:08 CET
This incident affected: ChurnIQ 2.0.