ChurnIQ - Degraded Performance of Exportable Tables

Incident Report for Cleeng

Resolved

The fix is deployed, exportable reports should now work as expected.
Posted Apr 01, 2026 - 16:32 CEST

Monitoring

A fix has been implemented and is ready for release.
Posted Apr 01, 2026 - 16:12 CEST

Investigating

We have identified an issue affecting exportable tables in the dashboard.

Some users may experience difficulty accessing the exportable tables in the publisher dashboard, however, the scheduled exports are not affected and are still being delivered as expected. Our team is actively investigating and working to restore full functionality.

We apologize for any inconvenience this may have caused.
Posted Apr 01, 2026 - 13:27 CEST
This incident affected: ChurnIQ.